Перейти к содержимому
ToolMug

Калькулятор IP-подсетей (CIDR)

Введите адрес с префиксом, например 192.168.1.10/24, чтобы получить всё о сети — адреса, маски, диапазон хостов и размер — для IPv4 и IPv6. Затем разбейте её на подсети меньшего размера или проверьте, принадлежит ли ей адрес.

Работает в браузере — введённые данные никуда не загружаются

Адрес сети192.168.1.0/24
Маска подсети255.255.255.0
Обратная маска (wildcard)0.0.0.255
Широковещательный адрес192.168.1.255
Первый доступный хост192.168.1.1
Последний доступный хост192.168.1.254
Доступных хостов254
Всего адресов256
Тип адресаЧастный (RFC 1918)
Двоичный вид11000000.10101000.00000001 | 00001010

Проверить, входит ли IP в этот диапазон

Разбить на подсети

Подсетей: 4

  1. 192.168.1.0/26
  2. 192.168.1.64/26
  3. 192.168.1.128/26
  4. 192.168.1.192/26

Как пользоваться

  1. Введите IP-адрес с префиксом (/24) или маской (/255.255.255.0). Без префикса считается, что указан один адрес.
  2. Посмотрите адрес сети, маски, диапазон доступных хостов и их количество.
  3. Укажите более длинный префикс в разделе «Разбить на подсети», чтобы разделить сеть.
  4. Введите адрес в поле «Проверить, входит ли IP в этот диапазон», чтобы узнать, принадлежит ли он сети.

Описание параметров

Доступных хостов
В IPv4 первый адрес — это адрес сети, а последний — широковещательный, поэтому в /24 доступно 254 хоста. Каналы «точка-точка» /31 (RFC 3021) и одиночные адреса /32 используют все адреса. В IPv6 широковещательного адреса нет.
Обратная маска (wildcard)
Инверсия маски подсети, используется в ACL Cisco и OSPF — 0.0.0.255 для /24.
Тип адреса
Отмечает частные диапазоны (RFC 1918), NAT операторского уровня, loopback, link-local, многоадресные диапазоны и диапазоны для документации.

Шпаргалка по префиксам

Префикс Маска сети Адресов Доступных хостов
/30 255.255.255.252 4 2
/29 255.255.255.248 8 6
/28 255.255.255.240 16 14
/27 255.255.255.224 32 30
/26 255.255.255.192 64 62
/25 255.255.255.128 128 126
/24 255.255.255.0 256 254
/23 255.255.254.0 512 510
/22 255.255.252.0 1 024 1 022
/16 255.255.0.0 65 536 65 534

Шпаргалка по IPv4 CIDR

Префикс Маска подсети Адресов Доступных хостов
/8 255.0.0.0 16 777 216 16 777 214
/12 255.240.0.0 1 048 576 1 048 574
/16 255.255.0.0 65 536 65 534
/20 255.255.240.0 4 096 4 094
/22 255.255.252.0 1 024 1 022
/23 255.255.254.0 512 510
/24 255.255.255.0 256 254
/25 255.255.255.128 128 126
/26 255.255.255.192 64 62
/27 255.255.255.224 32 30
/28 255.255.255.240 16 14
/29 255.255.255.248 8 6
/30 255.255.255.252 4 2
/31 255.255.255.254 2 2 (соединения «точка — точка», RFC 3021)
/32 255.255.255.255 1 1 (один хост)

Доступные хосты — это адреса за вычетом адреса сети и широковещательного адреса, кроме /31 и /32, где ничего не резервируется.

Пример

Адрес 192.168.1.130/26 принадлежит сети 192.168.1.128/26: доступные хосты занимают диапазон от 192.168.1.129 до 192.168.1.190, а 192.168.1.191 — широковещательный адрес; всего 62 хоста.

Частные диапазоны по RFC 1918 — это 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16; домашние маршрутизаторы обычно раздают адреса из сети /24 внутри 192.168.0.0/16.

Часто задаваемые вопросы

Сколько хостов в /24, /16 или /8?

254, 65 534 и 16 777 214 доступных хостов. Общее число адресов равно 2 в степени (32 − префикс).

Как разбить /24 на четыре подсети?

Используйте /26. В каждой /26 — 64 адреса (62 доступных) — .0, .64, .128 и .192.

Поддерживается ли IPv6?

Да. Адреса показываются в стандартной сокращённой форме (RFC 5952) и в полной записи, поддерживаются префиксы до /128.

Конфиденциальность

Этот инструмент работает полностью в браузере. Ваши файлы и текст обрабатываются на вашем устройстве и никогда не загружаются на наши серверы.

Похожие инструменты