本文へスキップ
ToolMug

IP サブネット(CIDR)計算機

192.168.1.10/24 のようにプレフィックス付きでアドレスを入力すると、アドレス、マスク、ホスト範囲、サイズなどネットワークの情報がすべてわかります。IPv4 と IPv6 に対応し、より小さなサブネットへの分割や、アドレスが範囲内かどうかの確認もできます。

ブラウザ内で動作 — 入力した内容はアップロードされません

ネットワークアドレス192.168.1.0/24
サブネットマスク255.255.255.0
ワイルドカードマスク0.0.0.255
ブロードキャストアドレス192.168.1.255
最初の使用可能ホスト192.168.1.1
最後の使用可能ホスト192.168.1.254
使用可能なホスト数254
アドレスの総数256
アドレスの種類プライベート(RFC 1918)
2 進数11000000.10101000.00000001 | 00001010

IP がこの範囲に含まれるか確認

サブネットに分割

4 個のサブネット

  1. 192.168.1.0/26
  2. 192.168.1.64/26
  3. 192.168.1.128/26
  4. 192.168.1.192/26

使い方

  1. IP アドレスを、プレフィックス(/24)またはサブネットマスク(/255.255.255.0)付きで入力します。プレフィックスがない場合は、単一のアドレスとして扱います。
  2. ネットワークアドレス、マスク、使用可能なホスト範囲とホスト数を確認します。
  3. ネットワークを分割するには、「サブネットに分割」でより長いプレフィックスを入力します。
  4. 「IP がこの範囲に含まれるか確認」にアドレスを入力すると、範囲内かどうかがわかります。

オプションの説明

使用可能なホスト数
IPv4 では最初のアドレスがネットワークアドレス、最後がブロードキャストアドレスなので、/24 で使用可能なホストは 254 個です。/31 のポイントツーポイントリンク(RFC 3021)と /32 の単一アドレスでは、すべてのアドレスを使います。IPv6 にはブロードキャストアドレスがありません。
ワイルドカードマスク
サブネットマスクを反転したもので、Cisco の ACL や OSPF で使われます。/24 なら 0.0.0.255 です。
アドレスの種類
プライベート(RFC 1918)、キャリアグレード NAT、ループバック、リンクローカル、マルチキャスト、ドキュメント用の範囲を判別して表示します。

プレフィックス早見表

プレフィックス ネットマスク アドレス数 使用可能なホスト数
/30 255.255.255.252 4 2
/29 255.255.255.248 8 6
/28 255.255.255.240 16 14
/27 255.255.255.224 32 30
/26 255.255.255.192 64 62
/25 255.255.255.128 128 126
/24 255.255.255.0 256 254
/23 255.255.254.0 512 510
/22 255.255.252.0 1,024 1,022
/16 255.255.0.0 65,536 65,534

IPv4 の CIDR 早見表

プレフィックス サブネットマスク アドレス数 使用可能なホスト数
/8 255.0.0.0 16,777,216 16,777,214
/12 255.240.0.0 1,048,576 1,048,574
/16 255.255.0.0 65,536 65,534
/20 255.255.240.0 4,096 4,094
/22 255.255.252.0 1,024 1,022
/23 255.255.254.0 512 510
/24 255.255.255.0 256 254
/25 255.255.255.128 128 126
/26 255.255.255.192 64 62
/27 255.255.255.224 32 30
/28 255.255.255.240 16 14
/29 255.255.255.248 8 6
/30 255.255.255.252 4 2
/31 255.255.255.254 2 2 (ポイントツーポイントリンク、RFC 3021)
/32 255.255.255.255 1 1 (単一のホスト)

使用可能なホスト数は、アドレス数からネットワークアドレスとブロードキャストアドレスを除いた数です。ただし /31 と /32 では、予約されるアドレスはありません。

例

192.168.1.130/26 は、ネットワーク 192.168.1.128/26 に属します。使用可能なホストは 192.168.1.129 から 192.168.1.190 まで、192.168.1.191 がブロードキャストアドレスで、ホストは合計 62 台です。

RFC 1918 のプライベートアドレス範囲は 10.0.0.0/8、172.16.0.0/12、192.168.0.0/16 です。家庭用ルーターは通常、192.168.0.0/16 の中の /24 からアドレスを割り当てます。

よくある質問

/24、/16、/8 のホスト数はいくつですか?

使用可能なホストはそれぞれ 254 個、65,534 個、16,777,214 個です。アドレスの総数は 2 の(32 − プレフィックス長)乗です。

/24 を 4 つのサブネットに分けるには?

/26 を使います。各 /26 には 64 個のアドレス(使用可能なのは 62 個)があり、.0、.64、.128、.192 から始まります。

IPv6 に対応していますか?

はい。アドレスは標準の省略表記(RFC 5952)と完全な展開表記の両方で表示され、/128 までのプレフィックスに対応しています。

プライバシー

このツールはすべてブラウザ内で動作します。ファイルやテキストはお使いの端末上で処理され、当サイトのサーバーにアップロードされることはありません。

関連ツール