Перейти к содержимому
ToolMug

Проверка DNS

Запросите DNS-записи и TTL домена, чтобы проверить сайт, почту и сертификаты. Выберите публичный DNS-резолвер или сравните все доступные, чтобы понять, распространилось ли изменение.

Обрабатывается на наших серверах и удаляется в течение часа

Как пользоваться

  1. Введите домен; можно вставить полный URL. По умолчанию выбраны все основные записи A, AAAA, CNAME, MX, TXT и NS, но можно выбрать один тип: A для сайта, MX для почты, TXT для проверки.
  2. Выберите DNS-сервер; сразу после изменения выберите «Все серверы (сравнить)».
  3. Нажмите «Проверить», чтобы увидеть значение и TTL каждой записи.

Описание параметров

Типы записей
A и AAAA — адреса IPv4 и IPv6, CNAME — псевдоним, MX — почтовые серверы, TXT используется для SPF и проверки, NS — авторитетные серверы, CAA — центры, которым разрешено выпускать сертификаты.
TTL
Сколько секунд запись может храниться в кэше. После изменения старые ответы могут оставаться до окончания TTL.
Обратный поиск
Выберите PTR и введите IP-адрес, чтобы найти его имя хоста.

Типы записей и где они определены

Тип Что хранит Где определён
A Адрес IPv4 RFC 1035
AAAA Адрес IPv6 RFC 3596
CNAME Псевдоним другого имени RFC 1035
MX Почтовый сервер и его приоритет (сначала пробуется меньшее значение) RFC 1035
TXT Произвольный текст, используется для SPF, DKIM и подтверждения прав на сайт RFC 1035
NS Авторитетные серверы имён зоны RFC 1035
SOA Начало полномочий зоны: основной сервер, серийный номер, таймеры RFC 1035
CAA Какие центры сертификации могут выпускать сертификаты RFC 8659
PTR Имя хоста для адреса (обратный поиск) RFC 1035
SRV Хост и порт службы RFC 2782

При обратном поиске запрашивается запись PTR для адреса, записанного в обратном порядке в зоне in-addr.arpa. Например, 192.0.2.10 ищется как 10.2.0.192.in-addr.arpa.

У имени, для которого есть CNAME, не может быть других собственных записей, поэтому CNAME нельзя использовать в вершине зоны, где обязаны существовать записи NS и SOA.

Часто задаваемые вопросы

Почему изменение DNS ещё не появилось?

Резолверы кэшируют старые ответы до окончания TTL. Вариант «Все серверы (сравнить)» покажет, какие резолверы уже видят новую запись.

Почему результаты отличаются от компьютера?

Компьютер может использовать DNS провайдера, прокси или файл hosts. Здесь результат поступает напрямую от выбранного публичного резолвера.

Поддерживаются ли интернационализированные домены?

Да. Перед запросом они преобразуются в Punycode, начинающийся с xn--.

Конфиденциальность

Файлы передаются по HTTPS для обработки и автоматически удаляются в течение часа.

Похожие инструменты