মূল বিষয়বস্তুতে যান
ToolMug

সরাতে ↑ ↓, খুলতে Enter, বন্ধ করতে Esc চাপুন।

DNS রেকর্ড অনুসন্ধান

আপনি ওয়েবসাইট, ইমেল ও সার্টিফিকেটের সেটিং যাচাই করতে কোনো ডোমেইনের DNS রেকর্ড ও TTL দেখতে পারেন। একটি পাবলিক রিজলভার বাছুন, অথবা সবগুলোর তুলনা করে দেখুন DNS পরিবর্তন ছড়িয়ে পড়েছে কি না।

আমাদের সার্ভারে প্রসেস হয় এবং এক ঘণ্টার মধ্যে মুছে ফেলা হয়

কীভাবে ব্যবহার করবেন

  1. একটি ডোমেইন লিখুন (সম্পূর্ণ URL পেস্ট করলেও কাজ হবে)। রেকর্ডের ধরন ডিফল্টভাবে সব প্রচলিত থাকে; এতে একসঙ্গে A, AAAA, CNAME, MX, TXT ও NS দেখা যায়। শুধু একটি দরকার হলে একটি ধরন বাছুন—ওয়েবসাইটের জন্য A, ইমেলের জন্য MX, যাচাইয়ের জন্য TXT।
  2. একটি DNS সার্ভার বাছুন; পরিবর্তন করার ঠিক পরেই সব সার্ভার (তুলনা) বাছুন।
  3. প্রতিটি রেকর্ডের মান ও TTL দেখতে খুঁজুন বোতামে ক্লিক করুন।

অপশনগুলোর ব্যাখ্যা

রেকর্ডের ধরন
A/AAAA হলো IPv4/IPv6 ঠিকানা, CNAME একটি alias, MX মেইল সার্ভার, TXT SPF ও যাচাইয়ের কাজে ব্যবহৃত হয়, NS হলো কর্তৃত্বপূর্ণ সার্ভার, আর CAA নির্ধারণ করে কোন certificate authority সার্টিফিকেট জারি করতে পারবে।
TTL
কোনো রেকর্ড কত সেকেন্ড cache হয়ে থাকতে পারে। পরিবর্তনের পর TTL শেষ না হওয়া পর্যন্ত পুরোনো উত্তর রয়ে যেতে পারে।
রিভার্স লুকআপ
PTR বাছুন এবং একটি IP ঠিকানা লিখে তার হোস্ট নাম খুঁজুন।

রেকর্ডের ধরন ও কোথায় সংজ্ঞায়িত

ধরন যা ধারণ করে সংজ্ঞায়িত
A IPv4 ঠিকানা RFC 1035
AAAA IPv6 ঠিকানা RFC 3596
CNAME অন্য নামের এলিয়াস RFC 1035
MX মেইল সার্ভার ও তার অগ্রাধিকার (কম সংখ্যাকে আগে চেষ্টা করা হয়) RFC 1035
TXT মুক্ত লেখা, SPF, DKIM ও সাইট যাচাইয়ে ব্যবহৃত RFC 1035
NS জোনের অথরিটেটিভ নেম সার্ভার RFC 1035
SOA জোনের কর্তৃত্বের সূচনা: প্রাইমারি সার্ভার, সিরিয়াল, টাইমার RFC 1035
CAA কোন সার্টিফিকেট অথরিটি সার্টিফিকেট ইস্যু করতে পারে RFC 8659
PTR কোনো ঠিকানার হোস্ট নাম (রিভার্স লুকআপ) RFC 1035
SRV কোনো সার্ভিসের হোস্ট ও পোর্ট RFC 2782

রিভার্স লুকআপে in-addr.arpa-র অধীনে উল্টো করে লেখা ঠিকানার PTR রেকর্ড চাওয়া হয়। যেমন, 192.0.2.10 খোঁজা হয় 10.2.0.192.in-addr.arpa হিসেবে।

যে নামে CNAME আছে, তাতে নিজস্ব অন্য রেকর্ড থাকতে পারে না। এ কারণেই জোন অ্যাপেক্সে CNAME অনুমোদিত নয়, কারণ সেখানে NS ও SOA রেকর্ড থাকতেই হবে।

সচরাচর জিজ্ঞাসিত প্রশ্ন

আমার DNS পরিবর্তন এখনো দেখা যাচ্ছে না কেন?

রিজলভারগুলো TTL শেষ হওয়া পর্যন্ত পুরোনো উত্তর cache করে রাখে। সব সার্ভার (তুলনা) কোন রিজলভারগুলো নতুন রেকর্ড দেখতে পাচ্ছে তা দেখায়।

আমার কম্পিউটারের ফলাফলের সঙ্গে ফলাফল মিলছে না কেন?

আপনার কম্পিউটার আপনার ইন্টারনেট প্রদানকারীর DNS, কোনো proxy বা hosts file ব্যবহার করতে পারে। এই ফলাফল সরাসরি বাছাই করা পাবলিক রিজলভার থেকে আসে।

আন্তর্জাতিকীকৃত ডোমেইন কি সমর্থিত?

হ্যাঁ। অনুসন্ধানের আগে এগুলো Punycode-এ (xn-- দিয়ে শুরু) রূপান্তর করা হয়।

গোপনীয়তা

প্রসেস করার জন্য ফাইলগুলো HTTPS-এর মাধ্যমে আপলোড হয় এবং এক ঘণ্টার মধ্যে স্বয়ংক্রিয়ভাবে মুছে ফেলা হয়।

সম্পর্কিত টুল